compressor problem
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,179
    Images
    2133
    Post Thanks / Like
    chop top mk2 is offline

    compressor problem

    wonder if anyone can help, having a problem with my compressor. its a abac lt 270, problem is before it gets up to pressure its releasing air from this valve.

    it does get up to pressure but not without releasing air, it dont sound right.

    if any one could help it would be much appeciated.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Administrator Darren West's Avatar
    Join Date
    Aug 2009
    Location
    braintree
    Posts
    14,069
    Images
    69
    Post Thanks / Like
    Darren West is offline
    that valve i believe is there to remove pressure from the cylinder until the motor has got the pump up to speed
    then it should close at a few psi

  4. #3
    Administrator blackpopracing's Avatar
    Join Date
    Apr 2009
    Location
    Slough
    Posts
    8,713
    Images
    1754
    Post Thanks / Like
    blackpopracing is offline
    yep, what Darren said. take it off and clean it if you need to.

  5. #4
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,179
    Images
    2133
    Post Thanks / Like
    chop top mk2 is offline
    thanks guys ,
    took valve off, turned out it was duff. ordered new one now works perfect. job sorted,

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Compressor problem
      By jackchitrodaz in forum Chat
      Replies: 3
      Last Post: 04-03-2011, 18:08
    2. Braking problem
      By kapri in forum Tech Discussion
      Replies: 10
      Last Post: 18-07-2009, 21:34
    3. indicator wiring problem!
      By sqweaka in forum Tech Discussion
      Replies: 12
      Last Post: 21-06-2009, 17:41
    4. air lift kit + compressor
      By 100ev8 in forum Stuff - FOR SALE
      Replies: 0
      Last Post: 17-06-2009, 19:07
    5. Electrics problem on my daily
      By Hemi Bucket in forum Tech Discussion
      Replies: 6
      Last Post: 17-05-2009, 19:01

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •