chop top mk2 - Page 203
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  87
+ Reply to Thread
Page 203 of 206 FirstFirst ... 103 153 193 201 202 203 204 205 ... LastLast
Results 2,021 to 2,030 of 2051

Thread: chop top mk2

  1. #2021
    Official RnS Addict mygasser's Avatar
    Join Date
    Dec 2009
    Location
    faversham, kent
    Posts
    13,413
    Images
    514
    Post Thanks / Like
    mygasser is offline
    that's a lot of jobs completed in 1 day, well done.
    neil.
    need a job done on your project? i may be able to help.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2022
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,250
    Images
    2211
    Post Thanks / Like
    chop top mk2 is offline
    cheers neil,
    i think i have bigger problems, the fitech is not reading the rpm signal so after 5 mins of running engine just cuts out. it will restart but wont run. i have contacted steve where i got the fitech from and this weekend i will try a couple of things he has advised and i am hoping that will sort the problem.
    was making some reel progress , bit gutted to be honest .

  4. #2023
    Administrator blackpopracing's Avatar
    Join Date
    Apr 2009
    Location
    Slough
    Posts
    9,188
    Images
    1774
    Post Thanks / Like
    blackpopracing is offline
    Fitech supplied sensors are reputedly rubbish. Changing them out for GM ones can often fix the issues.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #2024
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,250
    Images
    2211
    Post Thanks / Like
    chop top mk2 is offline
    problem not sorted. it does not have any error codes but it will tick over for a bit then the rev,s go up to 1700 rpm then the engine stops.

    i dont know enough about them blackpopracing to start messing. i will ring steve again on monday and see what he says and take it from there.

  7. #2025
    Rods 'n' Sods Junkie
    Join Date
    May 2015
    Location
    Birmingham
    Posts
    391
    Images
    2
    Post Thanks / Like
    drseg is offline
    a long shot that I came across on a k series rover that was still under warranty, would drive fine then suddenly run rougher and rougher till stopped dealer failed to find anything and it usually didn't play up was a mates wifes so after I'd experienced it, turned it off left a few secs and restarted running perfectly for a couple of minutes decided to check timing was ok and then suddenly as it misfired and spluttered and stopped, retarded retarded and retarded till it stopped, did it again and again looked under the exhaust manifold a loose nut on a support bracket rattling causing the anti knock sensor to retard the ignition till i9t wouldn't run and the rougher it ran the more it rattled and the more it retarded tightened it and problem disappeared, probably not but worth a quick check for anything loose

  8. #2026
    Administrator blackpopracing's Avatar
    Join Date
    Apr 2009
    Location
    Slough
    Posts
    9,188
    Images
    1774
    Post Thanks / Like
    blackpopracing is offline
    I've heard plenty of bad reports about Fitech, this is just another in a long list of them.

    Check the crank sensor - this is one of the most common issues.

  9. #2027
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,250
    Images
    2211
    Post Thanks / Like
    chop top mk2 is offline
    total no start today, i know this sounds stupid but its like it now has no rpm signal at all its like the wire has broke. i am going to check that wire with a meter on tuesday to see if there is any current running through it.
    i will ring steve tomorrow to see what he say,s and then go from there.

  10. #2028
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,330
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    if its a 2 wire sensor try swapping the wires over .
    Medusa + injection = too much torque for the dyno ..https://youtu.be/qg5o0_tJxYM

  11. #2029
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,250
    Images
    2211
    Post Thanks / Like
    chop top mk2 is offline
    its been a slow process but i think we might have solved the problem, i hope.
    the fitech all seems to work ok so it does not look like its fried its brain, it looks more like the throttle position sensors so steve has put two in the post and i should have them tomorrow.
    since the car came back from a show last year ( heavy rain all day and the bonnet of most of the time ) the car has had a very lumpy idle and i mean lumpy and it had got worse up to the point of the car not starting. the rpm would on tick over go up and down some 300/500 rpm and then towards the end the rpm would rise to about 1700 and then just die so may be that was the sensor giving up the ghost .

  12. #2030
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,250
    Images
    2211
    Post Thanks / Like
    chop top mk2 is offline
    parts have arrived,
    steve has sent out 2 throttle position sensors so tomorrow will see if it solves the problem.

+ Reply to Thread
Page 203 of 206 FirstFirst ... 103 153 193 201 202 203 204 205 ... LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Mk2 Zodiac Dash Top
      By Zody in forum Stuff - WANTED
      Replies: 0
      Last Post: 25-03-2010, 20:59
    2. chop saw/ w/shop heater
      By chris in forum Stuff - FOR SALE
      Replies: 4
      Last Post: 31-07-2009, 04:57
    3. mk2 consul bits
      By FugitiveGasser in forum Stuff - WANTED
      Replies: 9
      Last Post: 08-05-2009, 20:30
    4. zodiac mk2
      By pompeypaul in forum The Showroom
      Replies: 4
      Last Post: 30-04-2009, 19:43
    5. Transit MK2 steering box
      By Blown 100e in forum Tech Discussion
      Replies: 2
      Last Post: 28-04-2009, 20:54

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •