chop top mk2 - Reply to Topic
Have an account? Register

Forgot your password?

Forgot your username?

 

Reply to Thread

Post a reply to the thread: chop top mk2

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • Yesterday, 18:57
    blackpopracing
    Fitech supplied sensors are reputedly rubbish. Changing them out for GM ones can often fix the issues.
  • Yesterday, 18:23
    chop top mk2
    cheers neil,
    i think i have bigger problems, the fitech is not reading the rpm signal so after 5 mins of running engine just cuts out. it will restart but wont run. i have contacted steve where i got the fitech from and this weekend i will try a couple of things he has advised and i am hoping that will sort the problem.
    was making some reel progress , bit gutted to be honest .
  • 04-07-2020, 20:32
    mygasser
    that's a lot of jobs completed in 1 day, well done.
    neil.
  • 04-07-2020, 17:37
    chop top mk2
    to day has been pretty good,
    had a little to do list and got through most of it.
    starter just hanging up on flywheel when started, sorted 3mm shim plate.
    turbo oil feed pipe leaking, filter come loose sorted.
    exhaust leaking, exhaust paste sorted.
    the cable for the boot lid after 3 years of working decided to not work, and with no access to the boot i had to cut out the panel between the wheel tubs to get access . i had all ready made one when i did the new gearbox tunnel covers so today i got it fitted sorted.
    painted and fitted the amp in the boot, sorted.
    steering column bracket, the bracket was 1/2" thick and caught your toe when the clutch was released so i trimmed it down to 1/4" thick and rounded the edges and its now sorted.
    just got the brakes and the clutch to bleed tomorrow as i feel theres still a bit of air in the system.
  • 21-06-2020, 17:50
    chop top mk2
    i know where your coming from 69 ford but i like the wings to appear to finish and the grill to fit inside if you know what i mean.
  • 21-06-2020, 11:22
    69 ford
    I would've gone with the chrome headlight surround and bonnet trim, but I'm a MK2 fan and that's my opinion, look's superb though.
  • 20-06-2020, 20:16
    chop top mk2
    no it has a standard cam, was advised against a high lift cam as it runs a turbo.
  • 20-06-2020, 19:42
    ivanhoew
    is there much of a cam in it CT ?
  • 20-06-2020, 16:47
    chop top mk2
    i would like to try the chrome paint over white as i think it might give you a more silver finish rather than the black chrome i have.
    getting very close now with the car, i only have the gauges in the dash top to rewire as im getting a few weird going on,s and it dont make sense so i am just going to rewire and have done.
    car starts straight away now when the key is turned, i have adjusted the fitech to tick over at 800rpm but it does seem to hunt a bit from 850 to 950rpm so i might take it down a little more and see what happens.
  • 19-06-2020, 19:00
    ivanhoew
    nice to see the clear coat did not grey it down .
This thread has more than 10 replies. Click here to review the whole thread.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •