Mk3 Capri V8 - Reply to Topic
Have an account? Register

Forgot your password?

Forgot your username?

 

Reply to Thread

Post a reply to the thread: Mk3 Capri V8

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 07-12-2019, 23:57
    WB54
    Quote Originally Posted by Torment View Post
    That's a ****ter about the heads Phil.. I have some Corvette ally jobs sat here doing nowt..
    cheers for the offer, i did consider new ally heads but the Vortecs are hard to beat price wise, i have about 500 and about 8 hours porting in them and they should be good up to about 450bhp
  • 06-12-2019, 22:19
    cougarv8
    THAT is some progress mate, nice.

    68roadrunner
  • 06-12-2019, 16:17
    Torment
    That's a ****ter about the heads Phil.. I have some Corvette ally jobs sat here doing nowt..
  • 06-12-2019, 13:13
    69 ford
    Good luck with it all, never never give up.
  • 06-12-2019, 10:47
    blackpopracing
    Good luck & good luck with the new job.
  • 06-12-2019, 09:50
    WB54
    Picking this one back up, I've been rebuilding the motor since the summer, between waiting for bits, waiting on people to do what they've said (and taken ****en ages) and a few hiccups, I should have everything back by next weekend to put the motor back together. The short block is done, crank didn't need grinding. I gapped the rings properly, took all the flash off the pistons, sorted the rust within the lifter valley, found out why the dizzy wouldn't seat as the driven shaft wasn't pressed into the lob fully. Managed to crack one of the heads pulling out the pressed in studs, double gutted as they've had spring seats and guides cut down, must had been cracked already as it literally just fell apart. On inspection though the heads were knackered **** assembled to sell. Valve faces all pitted, seats recessed, old springs shimmed up, valve tips all mushroomed. So a set of new Vortec 062 heads were sourced.

    The engine will now be upgraded to a roller cam with 276 duration and .502 lift. The heads have been worked over, I've mild ported the bowls, blended the seats, polished the chambers, backcut the valves, tapped rocker posts for screw in studs and had a 3 angle valve job. I'll be running comp retainers for clearance to the guide, LS6 beehive 375lb springs and comp magnum roller rockers. Last thing to do is port match the inlet. I've also stepped up to a Holley 4150 650cfm carb from the 600. It's better sized for the 355 and with the 110LSA on the cam it won't kill engine vacuum so will still be pretty responsive.

    I've just taken voluntary redundancy and will have January off before I start my new job, so I'm really looking to push as hard as I can to get the motor and box back in, finish up some welding on it, finishing the brake/coilover conversion and the get the 9in under it. At the minute I get 4-5 hours on it every couple of weeks and whatever I can do quietly on a weeknight. Having 3-4 weeks of full days should see the progress I need to get it on the road for spring. fingers crossed.
  • 26-08-2019, 08:31
    Paul L
    WB54 Sorry to hear you have more engine work to do after your car was hit on the driveway.

    Hope your luck improves for the rest of the build, Paul.
  • 12-08-2019, 14:29
    WB54
    So after the fiasco of the car landing on the sump, I pulled the engine and box. While I had the sump off I though I'd check the big end as the oil pressure had dropped to 30 psi at idle when hot while breaking in the cam. It looks like it's had some debris go through them. Cranks not scored but does need a polish.

    I'm undecided as to whether to rebuild it completely or just reshell it on the assumption any **** is either in the bearing or filter. I think I'll be rebuilding it as the one of the mains isn't great at the cap join and if it's gone through the big end and mains, then odds are it's all gone through cam bearings as well.

  • 12-08-2019, 14:24
    WB54
    duplicate.
  • 26-06-2019, 12:59
    nobody
    Thats a proper ****er.

    Luckily no body damage
This thread has more than 10 replies. Click here to review the whole thread.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •