2k paint reaction
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Official RnS Addict
    Join Date
    Jan 2011
    Location
    manchester
    Posts
    1,302
    Images
    0
    Post Thanks / Like
    markmustang1 is offline

    2k paint reaction

    H i guys having a problem with a reaction on a 2k paint surface.My car was painted in 2k few years back,basecoat pearl and laquer,Re doing a few bit.Flatted it down and primed 2 small bits behind window,,got a paint reaction so flatted and isolated it.Flatted and when reprimed it.it came through a gain .isolated it again and put primer on dryish seemed ok come to put 2k base coat on and its reacted again any ideas???all 2k paint

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict corvette's Avatar
    Join Date
    Dec 2010
    Location
    Nottingknifegunshire
    Posts
    1,146
    Images
    64
    Post Thanks / Like
    corvette is offline
    did you flat through and have edges /layers to deal with, have you a fast thinner

  4. #3
    Administrator Darren West's Avatar
    Join Date
    Aug 2009
    Location
    braintree
    Posts
    14,069
    Images
    69
    Post Thanks / Like
    Darren West is offline
    i reckon the paint under the isolator is still soft
    once the isolator goes on don't flatten it down

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict
    Join Date
    Jan 2011
    Location
    manchester
    Posts
    1,302
    Images
    0
    Post Thanks / Like
    markmustang1 is offline
    Thanks for replies think I sorted I now.flatted it and put several dust coats on and dried with hair dryer between coats.seems to be ok,laquer it in 30 mins hope its ok paint was left to dry over night and didnt flat through the edges,bit weird,see what happens in 30 mins

  7. #5
    Official RnS Addict
    Join Date
    Jan 2011
    Location
    manchester
    Posts
    1,302
    Images
    0
    Post Thanks / Like
    markmustang1 is offline
    seems ok .must have put the first coat on a bit to thickly.thanks for replies guy,s

  8. #6
    Official RnS Addict panzer 4's Avatar
    Join Date
    Aug 2012
    Location
    liverpool
    Posts
    3,370
    Images
    586
    Post Thanks / Like
    panzer 4 is offline
    Quote Originally Posted by markmustang1 View Post
    Thanks for replies think I sorted I now.flatted it and put several dust coats on and dried with hair dryer between coats.seems to be ok,laquer it in 30 mins hope its ok paint was left to dry over night and didnt flat through the edges,bit weird,see what happens in 30 mins
    thats what i told ya last week lol, on dry,use hairdrier, glad it sorted mate, if ya was closer ide have done it for ya

  9. #7
    Official RnS Addict mygasser's Avatar
    Join Date
    Dec 2009
    Location
    faversham, kent
    Posts
    12,850
    Images
    514
    Post Thanks / Like
    mygasser is offline
    never sand isolator, it even says so on the tin. it forms a seal over the old paints so once sanded that seal is broken and you're back to square one.
    need a job done on your project? i may be able to help.

  10. #8
    Official RnS Addict
    Join Date
    Jan 2011
    Location
    manchester
    Posts
    1,302
    Images
    0
    Post Thanks / Like
    markmustang1 is offline
    I isolated it them primed on top,then flatted it.cheers guys

  11. #9
    Official RnS Addict mygasser's Avatar
    Join Date
    Dec 2009
    Location
    faversham, kent
    Posts
    12,850
    Images
    514
    Post Thanks / Like
    mygasser is offline
    what primer did you use?
    need a job done on your project? i may be able to help.

  12. #10
    Official RnS Addict
    Join Date
    Jan 2011
    Location
    manchester
    Posts
    1,302
    Images
    0
    Post Thanks / Like
    markmustang1 is offline
    2k,used on a few panels same as last time,but only reacted in 2 small places.bonnet was fully primed and it was fine,must have put too much a thick coat on first

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. paint, powder coat or stove enamel
      By Russ Gaylord Fontana in forum Tech Discussion
      Replies: 18
      Last Post: 22-03-2013, 13:51
    2. Query on header paint/coatings
      By evilzee28 in forum Tech Discussion
      Replies: 18
      Last Post: 10-05-2009, 21:43
    3. synthetic paint
      By fbiiburton in forum Tech Discussion
      Replies: 32
      Last Post: 08-05-2009, 17:56
    4. Du Pont solvent based paint - help
      By Hotrodder in forum Tech Discussion
      Replies: 8
      Last Post: 06-05-2009, 09:00
    5. garage floor paint
      By a40custom in forum Chat
      Replies: 3
      Last Post: 03-05-2009, 22:36

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •