351w non starter
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 71
  1. #1
    Jym
    I'm a grown up member now !
    Join Date
    Dec 2017
    Location
    Birmingham
    Posts
    23
    Images
    0
    Post Thanks / Like
    Jym is offline

    351w non starter

    Hi Everyone,

    It's a fresh motor (8.5 to 1 , rebore and new rings) and is showing about 130psi with a compression test.

    Has twin Edelbrock 1405 Carbs, floats set and all stock jets. Hit the throttle and the main jets are squirting fine.

    MSD 6 which tests out ok (bridge the trigger wires with coil lead earthed)

    Cylinder 1 is set at TDC on compression stroke with the rotor arm pointing at cylinder 1. rotor spins anti clockwise with correct firing order for 351w.

    When cranking it doesn't want to fire. With easy start it'll fire once and die. I've tried cranking and rotating the distributor either way, still nothing.

    Pulled the plugs, they look okay, not wet. Tried hitting the throttle several times to add more fuel, still no good. I have a 2" spacer onto the intake, a 6-71 blower with a 2" carb spacer.

    I'm confused, it has spark, ignition, the carbs are priming and squirting fuel but doesn't want to start? I've unbolted the carbs and raised them to make sure they aren't leaking fuel, they look fine.

    Any advice would be great, thanks in advance.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict timbo56's Avatar
    Join Date
    May 2016
    Location
    S E London
    Posts
    870
    Images
    22
    Post Thanks / Like
    timbo56 is offline
    Have you checked that you have got a spark at the plugs?

  4. #3
    Jym
    I'm a grown up member now !
    Join Date
    Dec 2017
    Location
    Birmingham
    Posts
    23
    Images
    0
    Post Thanks / Like
    Jym is offline
    Yes, spark at the plugs.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Rods 'n' Sods Junkie
    Join Date
    May 2015
    Location
    Somewhere West of London
    Posts
    127
    Images
    2
    Post Thanks / Like
    Test or Kill is offline
    At this time of year old style engines may need a lot more fuel to get going. Try to make sure the timing is at least close to where it should be and try chucking about 1/2 a cup of fresh petrol down the carbs and then crank it, or just give it a few good pumps on the gas pedal as long as you are sure the pump jets are squirting properly. The fact that you say it runs on easy start is the clue here. HTH
    Cheers, Martin

  7. #5
    Jym
    I'm a grown up member now !
    Join Date
    Dec 2017
    Location
    Birmingham
    Posts
    23
    Images
    0
    Post Thanks / Like
    Jym is offline
    I've always played with EFi engines so this carb business is pretty new to me. I'll try the half a cup of fuel direct into the carb and let you know how it goes.
    Thanks for your advice so far and taking the time to help.

  8. #6
    Jym
    I'm a grown up member now !
    Join Date
    Dec 2017
    Location
    Birmingham
    Posts
    23
    Images
    0
    Post Thanks / Like
    Jym is offline
    Okay, half a cup of fuel it fired up and cut out. reattempted to start and the motor sounded like it was trying to lock up. Another half cup and done the same again. Maybe it just need a tune up, can anyone recommend someone near the Birmingham area?

  9. #7
    Official RnS Addict
    Join Date
    Sep 2014
    Location
    The north
    Posts
    1,361
    Images
    1314
    Post Thanks / Like
    nuggets is offline
    Half a cup?? Way too much

    Anyway if you had it apart did you degree the cam and make sure the chain was set right?

    You may also want to check your timing marks

    Should fire and run at 6-12btdc

  10. #8
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,097
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    fresh fuel in the tank ?
    Bicester scramble ,Medusa enjoyed the trip.https://www.youtube.com/watch?v=Q-7I7-nA19U

  11. #9
    Rods 'n' Sods Junkie
    Join Date
    May 2015
    Location
    Somewhere West of London
    Posts
    127
    Images
    2
    Post Thanks / Like
    Test or Kill is offline
    Half a cup?? Way too much
    Depends where you are in the UK, you are Oop North, cups are different there. Anyway, it should keep running so sounds like the carbs may not have fuel. Pump working OK?
    Cheers, Martin

  12. #10
    Official RnS Addict timbo56's Avatar
    Join Date
    May 2016
    Location
    S E London
    Posts
    870
    Images
    22
    Post Thanks / Like
    timbo56 is offline
    Assuming the cam is timed correctly and the distributor is putting out more than one spark and/or you don't have a faulty box then it'll be ignition timing related, are you sure it's not 180 degrees out (easily dome) and make sure the rotor is pointing before No.1 and turn the dizzy as you get someone to turn the key.
    Any engine should run, even roughly providing you have a spark, petrol and near correct timing.
    One other thing, are there any air leaks inlet side such as unblocked vacuum pipes?
    Last edited by timbo56; 17-12-2017 at 18:30.

+ Reply to Thread
Page 1 of 8 1 2 3 ... LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. 350 SBC Non Starter
      By road rage in forum Tech Discussion
      Replies: 0
      Last Post: 17-11-2012, 14:49
    2. Non starter
      By jon100e in forum Tech Discussion
      Replies: 6
      Last Post: 18-09-2012, 12:16
    3. SBC starter advice
      By boyceeeee in forum Tech Discussion
      Replies: 15
      Last Post: 16-05-2009, 07:57
    4. well heres another non nsra member lol
      By robford in forum Who are ya ??
      Replies: 1
      Last Post: 24-04-2009, 21:41

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •