Cortina auto box problem .
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Cortina auto box problem .

    It was all working fine when I parked it up 8 months ago ( is it really that long?! ) but during trial runs to check everything over before a fresh MOT it appears to be playing up but only in D . Floor it and it will hit 4500 before slipping and dropping back to 3000 . The box has only done 6000 miles since rebuild .

    Kickdown is adjusted up and fresh fluid .It'll rev out with no slipping in 1 and as fast as I can go before running out of road in 2 .Suck test tells me the new modulator is still working so . My best guess is modulator pin stuck on making it think I'm on light throttle all the time ?

    Anyone else have any other ideas ?

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Rods 'n' Sods Junkie dubmeister's Avatar
    Join Date
    Jun 2009
    Location
    carlisle
    Posts
    393
    Images
    0
    Post Thanks / Like
    dubmeister is offline

    Re: Cortina auto box problem .

    Band adjustment screw need a tweak ? can't think of anything else thats adjustable or goes wrong .
    Fluid change maybe help?

  4. #3
    drag race addict redvictor's Avatar
    Join Date
    Apr 2009
    Location
    wolverhampton
    Posts
    1,392
    Images
    0
    Post Thanks / Like
    redvictor is offline

    Re: Cortina auto box problem .

    Governer and modulator circuits are used in D Kev. My guess is the lay up has made something stick. Both gov and mod valve when at rest should make it late shift when stuck but they could have moved on the initial drive and stuck.
    Also pressure reg valve could be sticking. Some Activ8 could free them off if that is the case. Or obviously strip and check.
    Europe's quickest and fastest street legal car. 4.09 @ 191 - 6.27 @ 237mph so far...
    IVA legal too!
    Penn Autos/Andy Frost race transmissions.
    www.redvictor1racing.co.uk

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Re: Cortina auto box problem .

    Well I changed the modulator for another known good one and took it for a run...no difference.

    Added some Lubegard ,automatic transmission protectant and took it for around a 5 mile run on light throttle to mix it all in ...no difference.

    Blanked off the modulator ,on the basisi it shouldlmake it hang on to gears ...it didn't .

    Does that help pinpoint it Andy ?

  7. #5
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Re: Cortina auto box problem .

    I've stripped the back of the box off to check whether the governor was sticking and I'm told there should be a spring in there . I felt no resistance at all so stripped the circlip off the valve end and caught the shuttle valve and that was it ...no spring at all ?
    The thing is this was working fine when I took it off the road so what's going on ?

    I've tried searching the 'net for info re the C3 but can't find anything , a parts diagram even wouldlbe helpful. Anyone got a link stashed away somewhere ?

  8. #6
    drag race addict redvictor's Avatar
    Join Date
    Apr 2009
    Location
    wolverhampton
    Posts
    1,392
    Images
    0
    Post Thanks / Like
    redvictor is offline

    Re: Cortina auto box problem .

    Quote Originally Posted by kapri View Post
    I've stripped the back of the box off to check whether the governor was sticking and I'm told there should be a spring in there . I felt no resistance at all so stripped the circlip off the valve end and caught the shuttle valve and that was it ...no spring at all ?
    The thing is this was working fine when I took it off the road so what's going on ?

    I've tried searching the 'net for info re the C3 but can't find anything , a parts diagram even wouldlbe helpful. Anyone got a link stashed away somewhere ?
    I'll have a look at my manual tomorrow Kev to double check there is a spring on a C3.Pretty damn sure there is,and pretty sure there isn't a circlip either.
    Europe's quickest and fastest street legal car. 4.09 @ 191 - 6.27 @ 237mph so far...
    IVA legal too!
    Penn Autos/Andy Frost race transmissions.
    www.redvictor1racing.co.uk

  9. #7
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Re: Cortina auto box problem .

    I'm way beyond my experience here

    The governor assembly casting bolts to the rear with 4 bolts.

    One end has a weight with an inner cylinder and spring held in with circlips . The other end is a stepped shuttle ,this is where I thought there should be another spring ? There is a pin assembly that goes though the complete assembly with a circlip on the end.

    I presume this spring was needed to balance the pull of the weight moving in its housing to move the shuttle over 2 hydraulic access ports.

    Otherwise I can only assume that the weight operates against the pressure of the hydraulic fluid?

    I can't belive it's missing though, nowhere for it to disappear to apart from down the two hydraulic ports ?

  10. #8
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Re: Cortina auto box problem .

    This was posted up for me by Paul Nichols

    http://www.jpat.co.uk/Ford%20C3.pdf

    When I initially looked at it I thought I was going mad and looking at teh wrong part until I realised there are 2 different bodies and I have the early ( marked as 1974 on the governor body ) 4 bolt version .

  11. #9
    drag race addict redvictor's Avatar
    Join Date
    Apr 2009
    Location
    wolverhampton
    Posts
    1,392
    Images
    0
    Post Thanks / Like
    redvictor is offline

    Re: Cortina auto box problem .

    Ah ok,but there still should be a spring in there.I thought it should be the other governer pictured with the 2 bolts.
    Europe's quickest and fastest street legal car. 4.09 @ 191 - 6.27 @ 237mph so far...
    IVA legal too!
    Penn Autos/Andy Frost race transmissions.
    www.redvictor1racing.co.uk

  12. #10
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,081
    Images
    12
    Post Thanks / Like
    kapri is offline

    Re: Cortina auto box problem .

    There is a spring Andy but only in the weight end not the shuttle end ,exactly per the early governor diagram?

    I remembered we spoke about pulling 2 bolts only which is when I realised what was going on.

    When it's in your hands it hard to work out how it works .I couldn't see why the weight needs a spring in it and not the other end as it looks like there's nothing to prevent the weight flying out as soon as you to drive. Hence why I guessed it must be kept back by the hydraulic pressure and that pressure must compress the weight end internal spring .

    Presumably as it's sprinning the weight moves outwards and must pull on the rod passing through the shuttle (when the spring compresses) allows the shuttle to move?

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. 85 z28 fuel problem
      By tuckers in forum Tech Discussion
      Replies: 2
      Last Post: 03-05-2010, 13:07
    2. V6 oil pressure problem
      By Tiddytime in forum Tech Discussion
      Replies: 5
      Last Post: 22-11-2009, 21:33
    3. Browser problem
      By kapri in forum Chat
      Replies: 13
      Last Post: 22-10-2009, 00:22
    4. c4 gear box problem
      By old pizz yella in forum Tech Discussion
      Replies: 18
      Last Post: 16-08-2009, 16:57
    5. Cortina auto mount ?
      By kapri in forum On Topic
      Replies: 7
      Last Post: 15-05-2009, 22:09

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •