Drawthrough Turbo Help - Page 17
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 17 of 17 FirstFirst ... 7 15 16 17
Results 161 to 168 of 168
  1. #161
    Official RnS Addict
    Join Date
    Mar 2010
    Location
    Gone
    Posts
    918
    Images
    13
    Post Thanks / Like
    fall-apart-dave is offline
    New jets are in. Larger idles and larger pump jets.

    She will tickover now without choke. Choke on kills the engine once warm.

    Steady opening throttle revs fine

    Sudden opening throttle spits and backfires

    Idle mixture screws have no effect

    Idle is not steady. It picks up and drops periodically.

    Butterflies are as closed as they physically can be


    So... Getting somewhere at least. I think a stronger spring in the accelerator pump will help squirt fuel faster, still not enough fuel when opening the throttle quickly.
    I think that it is either idling on progression somehow, or there's a vac leak somewhere, or both.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #162
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,038
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    or something is blocking the fuel gallery to the idles?
    Bicester scramble ,Medusa enjoyed the trip.https://www.youtube.com/watch?v=Q-7I7-nA19U

  4. #163
    Official RnS Addict
    Join Date
    Mar 2010
    Location
    Gone
    Posts
    918
    Images
    13
    Post Thanks / Like
    fall-apart-dave is offline
    Nah, were that the case the progression on steady opening of throttle would not be so steady surely? Unless a small blockage I suppose. Worth looking at when I next look at it I guess!

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #164
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,038
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    Nah, were that the case the progression on steady opening of throttle would not be so steady surely? Unless a small blockage I suppose. Worth looking at when I next look at it I guess!




    it depends on the choke sizes as to when it pulls up on the main jet circuit .if the chokes are small enough ,and main jet big enough , it could be on that circuit v early so covering up the lean area ..

    .if the idle screws are having no effect ,that's a possible sign of the idles not getting enough fuel .

    a bit of a rule of thumb is , if the blades are not open too far and sucking on the progressions , then the idles tend to end up 2.5 turns open at best tickover mix , this is a rough way to find if you have a reasonably correct jet size .

    but the screws should definitely have an effect.

    it is common for webers and dellorto's if fuel is left to evap in them to get blocked galleries , sometimes needing the lead shot drilling out and rods put down the tubes ,then re lead shotted .


    regards
    robert.
    Bicester scramble ,Medusa enjoyed the trip.https://www.youtube.com/watch?v=Q-7I7-nA19U

  7. #165
    Official RnS Addict
    Join Date
    Mar 2010
    Location
    Gone
    Posts
    918
    Images
    13
    Post Thanks / Like
    fall-apart-dave is offline
    Gotcha. Will have a close look when I'm home.

  8. #166
    Official RnS Addict
    Join Date
    Mar 2010
    Location
    Gone
    Posts
    918
    Images
    13
    Post Thanks / Like
    fall-apart-dave is offline
    A LOT of tinkering later... She starts, runs, drives, doesn't backfire any more... You'd think that would be the end of my woes, right? LOL!

    So, I got an MOT, drove it to my wedding, all great stuff. But... When it came to actually setting the boost, I got zip. Nothing. No boost whatsoever.

    Here's why:



    Lovely hole right on the wastegate hole and a good chunk missing. Constantly passing gas, preventing any boost from building. Great stuff.

    So, needs a new housing for the turbo.

    But also found why the buggered fuelling, weird symptoms, fouled plugs, sooty dirty exhaust, and other woes... The turbo is dynamic sealed, not carbon sealed. Closed throttle = vacuum in turbo = unseated shaft seal = oil in the intake. So, I need to convert the turbo to a carbon shaft seal (after repairing it) and then see what it does. OR, find a carbon shaft sealed turbo... Can I find one? Can I balls! Got loads of part numbers that supposedly have carbon seals:


    TB0319 Renault
    TB0327 Pug
    TB0390 Merc
    TC0304 Citreon
    TA0305 Renault
    TB0307 Ford
    TB0310 Renault
    TB0308 buik
    tb0309 buik
    tb0317 buick
    TB0346 pug
    tb0360 merc
    TB0369 Merc
    TB0344 Ford
    TB0371 / 78 / 75 Crysler / Dodge
    TB0355 Dodge
    TB0306 Nissan


    Does anyone know of any others, and better yet know of one for sale? :-) Nope, neither do I!! GRRR!

    On it goes...

  9. #167
    Rods 'n' Sods Junkie
    Join Date
    Mar 2012
    Location
    leed uk
    Posts
    364
    Images
    28
    Post Thanks / Like
    mcmental is offline

  10. #168
    Official RnS Addict
    Join Date
    Mar 2010
    Location
    Gone
    Posts
    918
    Images
    13
    Post Thanks / Like
    fall-apart-dave is offline
    Bit steep for my matey but cheers.

    Well the turbo is rebuilt ready to go back on... Just waiting for the resto bloke it is with to weld my new framehead bottom plate in then I can collect it and play!

+ Reply to Thread
Page 17 of 17 FirstFirst ... 7 15 16 17

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Help needed with compound turbo set up
      By nikb in forum Tech Discussion
      Replies: 8
      Last Post: 08-10-2014, 16:19
    2. Replies: 14
      Last Post: 02-06-2013, 11:26
    3. Du Pont solvent based paint - help
      By Hotrodder in forum Tech Discussion
      Replies: 8
      Last Post: 06-05-2009, 08:00
    4. Help finding shocks
      By roofer in forum On Topic
      Replies: 0
      Last Post: 05-05-2009, 11:22
    5. Can someone help me...???
      By bigyellataxi in forum Chat
      Replies: 6
      Last Post: 23-04-2009, 17:31

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •