Essex V6 ignition help please...
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 67
  1. #1
    Official RnS Addict bigyellataxi's Avatar
    Join Date
    Apr 2009
    Location
    Leicester
    Posts
    5,691
    Images
    592
    Post Thanks / Like
    bigyellataxi is offline

    Essex V6 ignition help please...

    Ok, so I've got a 3 litre V6 Essex in the Pop, it has a universal wiring loom in it, dizzy/coil is wired up how I think it should be, feed from loom to + ve side of coil, also a wire from alternator to + ve side, - ve side has points only, there is NO ballast resistor.
    Dizzy is a black capped Motorcraft (?), main problem is very rough running when in drive, ticking over it's fine, revs cleanly etc, but in any gear it pulls itself down and hardly runs on anything over no throttle...

    Now, should I:

    A) bin points + condensor and fit an Accuspark electronic kit,

    Or

    B) fit a ballast resistor????


    Guy

    Fueled by Jim and Luckies.
    Still doing all the shit I used to ;-)
    Quick reply to this message Reply  

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    22,858
    Images
    12
    Post Thanks / Like
    kapri is online now
    Do you know what resistance the coil is as that will tell you if you need a ballast resistor or not. I would'nt think that would give the sympthoms you have Does it tickover fine in Drive or does it start to play up as soon as you put it into drive?
    Quick reply to this message Reply  

  4. #3
    Official RnS Addict bigyellataxi's Avatar
    Join Date
    Apr 2009
    Location
    Leicester
    Posts
    5,691
    Images
    592
    Post Thanks / Like
    bigyellataxi is offline
    When I got the new coil/points/condensor I stated it was for a NON ballast car, so hopefully...

    I'll tickover fine in drive, it's just as soon as you take it that bit further on the throttle...

    It was warm (motor), the only thing I haven't attached wiring wise is the alternator exciter wire, but I wouldn't have thought that would cause running issues...???

    It's almost as if there is a fuelling issue, if I could figure out how to put the video link on here others would be able to listen to it...

    Ooh, hang on, try this:

    https://www.youtube.com/watch?v=cUJ7ElhIXGM

    Fueled by Jim and Luckies.
    Still doing all the shit I used to ;-)
    Quick reply to this message Reply  

  5. #4
    richard rawlplug Torment's Avatar
    Join Date
    Apr 2009
    Location
    nottafukinchancingham
    Posts
    7,765
    Images
    56
    Post Thanks / Like
    Torment is offline
    Crap in the carb..?

    My rover did that...


    The Oddlot Drag Racing Team...havin fun is usual
    57 bel air wagon
    540cui altered.
    your not drunk enough if you can lie on the floor without holding on..
    Quick reply to this message Reply  

  6. #5
    Official RnS Addict mygasser's Avatar
    Join Date
    Dec 2009
    Location
    faversham, kent
    Posts
    12,550
    Images
    514
    Post Thanks / Like
    mygasser is offline
    hi guy, what's the purpose of the wire from the alternator to the +ve side of the coil? neil.
    need a job done on your project? i may be able to help.
    Quick reply to this message Reply  

  7. #6
    Official RnS Addict bigyellataxi's Avatar
    Join Date
    Apr 2009
    Location
    Leicester
    Posts
    5,691
    Images
    592
    Post Thanks / Like
    bigyellataxi is offline
    Neil, I can't remember, when I took the alternator to a clever bloke I'm sure he said that was what I should do.

    That was 4 years ago though...

    I'm gonna take it off and get him to recheck which terminals should be used and what goes where...

    Would that cause any rough running though??

    Fueled by Jim and Luckies.
    Still doing all the shit I used to ;-)
    Quick reply to this message Reply  

  8. #7
    Official RnS Addict brading's Avatar
    Join Date
    Sep 2011
    Location
    Kings Lynn
    Posts
    2,864
    Images
    332
    Post Thanks / Like
    brading is offline
    Hi Guy can you post a picture of the back of your alternator and any info on the alternator. Cannot see any reason why you would need a wire from the coil to the alternator. I take it you have a wire from the ignition switch to the alternator exciter terminal. cheers Paul
    Last edited by brading; 19-02-2015 at 14:07.
    Quick reply to this message Reply  

  9. #8
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    22,858
    Images
    12
    Post Thanks / Like
    kapri is online now
    Guy, would you like to take the carb off and send it to me so I can go through it ?
    Quick reply to this message Reply  

  10. #9
    Semi Proffessional Prat sidspop's Avatar
    Join Date
    Apr 2009
    Location
    YamYam central
    Posts
    3,489
    Images
    453
    Post Thanks / Like
    Images
    74
    sidspop is offline
    Bit of a wierd one this Guy, there are so many things that it could be, but just one cure.
    There are two distinct posssibilities , fuelling or sparks. There are lots of stab in the dark ideas also, such as bad earth to the engine block, but if you are starting it and it starts ok that would rule that one out.

    Generally, the big bog off wire from the alternator goes to the battery, or uses a terminal on the solenoid which is then connected to battery. The little wire goes up to the dash, via the battery bulb and then to 12 volts ignition. That is the way that 99% of alternators are wired, and I see no reason why it should go to the loom. If it were my car, I would correct this.

    Is it a manual, or auto box?
    Its either you lay down and die or you get on with your shit till you do!!!!! No Other Way Around It. One or the other. Don't worry about being forgotten, you will. Rather worry about in how long it will take for you to be forgotten, bro.
    Quick reply to this message Reply  

  11. #10
    I'm a grown up member now !
    Join Date
    Jun 2011
    Location
    Barnsley
    Posts
    25
    Images
    0
    Post Thanks / Like
    Kieranzxt is offline
    Check the voltage at the coil 12v means non ballast, 9v ballast.
    Have you checked the timing? Does it rev up ok with no load?
    Quick reply to this message Reply  

Page 1 of 7 1 2 3 ... LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Similar Threads

  1. Replies: 2
    Last Post: 24-08-2013, 12:40
  2. Off Topic Help please - Daily - BMW
    By shoebox in forum Tech Discussion
    Replies: 6
    Last Post: 18-01-2011, 05:31
  3. speedo help please
    By wheelie in forum Tech Discussion
    Replies: 10
    Last Post: 03-09-2009, 14:21
  4. help please
    By 58 delray in forum Chat
    Replies: 2
    Last Post: 08-07-2009, 08:03
  5. Help please folks !!
    By andy fadster in forum On Topic
    Replies: 7
    Last Post: 06-07-2009, 18:17

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •