Flathead ignition help
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    I'm a grown up member now !
    Join Date
    Jan 2015
    Location
    Down south
    Posts
    42
    Images
    1
    Post Thanks / Like
    rachet is offline

    Flathead ignition help

    I need a little help tracing a ongoing problem. I've got a flathead with the diving bell style distributor it starts and runs fine until it gets hot (maybe around 160*) then it wont rev and has no power and dies then wont start until it cools down. Its had new fuel pump, carb, coil , condenser, ballast resistor, plugs, and still it persists any help appreciated!

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict
    Join Date
    Jun 2016
    Location
    Roswell, New Mexico
    Posts
    636
    Images
    0
    Post Thanks / Like
    NMNeil is offline
    Valves too tight and staying open, as the valve stem expands when it gets hot?
    Free and easy to check.

  4. #3
    Official RnS Addict timbo56's Avatar
    Join Date
    May 2016
    Location
    S E London
    Posts
    870
    Images
    22
    Post Thanks / Like
    timbo56 is offline
    Quote Originally Posted by NMNeil View Post
    Valves too tight and staying open, as the valve stem expands when it gets hot?
    Free and easy to check.
    I had that problem with an old 1936 Rolls I used to drive, it'd cut out on tickover when hot and not restart for a while, very embarrasing when you have a new bride and groom in the back. Turns out the bloke who owned it had run it solely on unleaded and the valve seats had worn down and the clearances were non existent when hot

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict 35kid's Avatar
    Join Date
    Apr 2009
    Location
    up north
    Posts
    1,987
    Images
    3
    Post Thanks / Like
    35kid is offline
    i would try another condenser, new ones don't have a good reputation.

  7. #5
    Official RnS Addict
    Join Date
    Jun 2016
    Location
    Roswell, New Mexico
    Posts
    636
    Images
    0
    Post Thanks / Like
    NMNeil is offline
    Quote Originally Posted by 35kid View Post
    i would try another condenser, new ones don't have a good reputation.
    Can't see that making any difference.

  8. #6
    I'm a newbie !
    Join Date
    Sep 2012
    Location
    Burlington, Wisconsin, USA
    Posts
    3
    Images
    2
    Post Thanks / Like
    jmbo is offline
    If you are using a mechanical fuel pump take look at the push rod. They wear and at some point they wear to the point were they will not fully activate the pump. When flatheads get hot the fuel tends to vaporize. This is very common and is due to the manifold sitting directly atop the motor. This results in what is called vapor lock and the engine will not perform properly. To prevent this you need a full functional fuel pump. Good luck.

  9. #7
    Official RnS Addict zefa46's Avatar
    Join Date
    Apr 2009
    Location
    Westhoughton Bolton lancs
    Posts
    1,424
    Images
    177
    Post Thanks / Like
    zefa46 is offline
    sounds similar to mine , turned out to be the vac advance diaphragm $6 fix , take it off and blow through it . minr ticked over ok but got hot and boiled when run. easy fix and easy test worth a try

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Flathead ignition
      By rachet in forum Stuff - WANTED
      Replies: 0
      Last Post: 30-03-2017, 19:07
    2. Ignition Help
      By sedatev8 in forum Tech Discussion
      Replies: 7
      Last Post: 12-10-2016, 19:46
    3. Essex V6 ignition help please...
      By bigyellataxi in forum Tech Discussion
      Replies: 66
      Last Post: 10-03-2015, 22:09
    4. help with ignition timing?
      By scrapyarddoguk in forum Tech Discussion
      Replies: 3
      Last Post: 27-02-2012, 18:28
    5. 2.0 Pinto electronic ignition :( wiring help
      By lowriderchris in forum Tech Discussion
      Replies: 3
      Last Post: 23-10-2011, 12:01

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •