Holley carb tuning - Page 4
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 4 of 7 FirstFirst ... 2 3 4 5 6 ... LastLast
Results 31 to 40 of 65
  1. #31
    Rods 'n' Sods Junkie
    Join Date
    Feb 2010
    Location
    london
    Posts
    458
    Images
    0
    Post Thanks / Like
    zephyrc is offline
    disconnect the vacuum on the dizzy if you have it ,,, connect timing light ,,, if the damper is fully degree marked find the 38 degree and mark it with tippex or white paint.... if the damper is not fully marked beg borrow or steal a dial back timing light......get a mate or the missus to watch the tach .... rev to about 3500 and hold it there so all the mechanical advance is in and see what it is,,,, adjust to around 38 degrees ...
    sbc can run up to 20 degrees initial as long as you limit the total to about 38 degrees... what ignition system do you use, msd.crane etc

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #32
    Carburation 'sucks' Roscobbc's Avatar
    Join Date
    Apr 2009
    Location
    South West Essex
    Posts
    4,093
    Images
    14
    Post Thanks / Like
    Roscobbc is offline
    No one has discussed the compression ration of your engine? - are you using Shell VPower Super Unleaded - if can make a surprising difference - mine with 10.5 c/r will tend to run 'off' and pink a bit if not used!

  4. #33
    Rods 'n' Sods Junkie SpannerPete's Avatar
    Join Date
    Nov 2009
    Location
    Bedfordshire
    Posts
    301
    Images
    19
    Post Thanks / Like
    SpannerPete is offline
    It's 10.5 cr. Just using standard 95 petrol, could this cause a problem?

    Waiting to hear back about cam specs...

    Ordered some lamda sensors and bungs so I can check the mixture.

    Will recheck the timing when I get a minute

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #34
    Rods 'n' Sods Junkie
    Join Date
    Feb 2010
    Location
    london
    Posts
    458
    Images
    0
    Post Thanks / Like
    zephyrc is offline
    With that compression and that cam I would expect the vacuum to be about 15 at idle. I would check timing and if that's ok look carb. Take it off. Spin it over and check the idle slots.. should look like squares when correct. WHen cruising what vacuum does the motor have. LAmba sensors are good but you can just as easily sort it by checking the plugs

  7. #35
    Rods 'n' Sods Junkie SpannerPete's Avatar
    Join Date
    Nov 2009
    Location
    Bedfordshire
    Posts
    301
    Images
    19
    Post Thanks / Like
    SpannerPete is offline
    Quote Originally Posted by zephyrc View Post
    With that compression and that cam I would expect the vacuum to be about 15 at idle. I would check timing and if that's ok look carb. Take it off. Spin it over and check the idle slots.. should look like squares when correct. WHen cruising what vacuum does the motor have. LAmba sensors are good but you can just as easily sort it by checking the plugs
    Not had time to check the timing yet but from previous experiments the following mayor may not be relevant but relate to the questions above: Please note I have always been trying to cure the same problem.

    When I first tried to set the idle I found that it would still run with the idle jets wound right in so I supected a faulty power valve. New power valve, same problem. I then found the secondary butterflys were slightly open so I closed them off with the adjusting screw. Idle can now be set correctly.

    I did take the carb off to check the slots. Secondary ones can't be seen, primary ones are square. I must admit from what I had read I would have expect to have to open the butterflys a lot more to get it to idle with low vacuum.

    Vacuum when cruising is about 15" (light throttle 1400rpm) , and I have the problem at this vacuum and rpm.

  8. #36
    Rods 'n' Sods Junkie
    Join Date
    Feb 2010
    Location
    london
    Posts
    458
    Images
    0
    Post Thanks / Like
    zephyrc is offline
    what size power valve is in there,, how far out are the idle mixture screws now

  9. #37
    Rods 'n' Sods Junkie SpannerPete's Avatar
    Join Date
    Nov 2009
    Location
    Bedfordshire
    Posts
    301
    Images
    19
    Post Thanks / Like
    SpannerPete is offline
    Quote Originally Posted by zephyrc View Post
    what size power valve is in there,, how far out are the idle mixture screws now
    Was a 4.5 power valve but real steal only had 5 in stock so I fitted one of those. I've since had the original 4.5 tested and it's ok so I could put that back.

    Idle mixture screws are out about 1.5 turns

  10. #38
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,114
    Images
    12
    Post Thanks / Like
    kapri is online now
    Where are you taking the vacuum readings from ? Sounds like it is on a ported vacuum rather than full manifold vacuum and if that is the case then the vac advance pipe may also b eon an incorrect port ?

  11. #39
    Rods 'n' Sods Junkie SpannerPete's Avatar
    Join Date
    Nov 2009
    Location
    Bedfordshire
    Posts
    301
    Images
    19
    Post Thanks / Like
    SpannerPete is offline
    Quote Originally Posted by kapri View Post
    Where are you taking the vacuum readings from ? Sounds like it is on a ported vacuum rather than full manifold vacuum and if that is the case then the vac advance pipe may also b eon an incorrect port ?

    Advance is connected to 1

    Vacuum gauge is connect to 2



    I just wish it is something silly like this

  12. #40
    Exceeded sell by date Plumpcars's Avatar
    Join Date
    Apr 2009
    Location
    London Heathrowish!
    Posts
    7,721
    Images
    46
    Post Thanks / Like
    Plumpcars is offline
    I would have a complete check otf the timing set up before going further. Your advance is connected to a ported take off and it could run better if connected to full vacuum at 2.

+ Reply to Thread
Page 4 of 7 FirstFirst ... 2 3 4 5 6 ... LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Marc 55 Chev Carb tuning
      By ozzie in forum Chat
      Replies: 11
      Last Post: 04-07-2010, 23:51
    2. holley carb plus rover v8 bits
      By harris66 in forum Stuff - WANTED
      Replies: 1
      Last Post: 31-01-2010, 19:58
    3. holley carb id ?
      By 100ev8 in forum Tech Discussion
      Replies: 1
      Last Post: 01-10-2009, 20:59
    4. holley carb question
      By vw2v8 in forum Tech Discussion
      Replies: 4
      Last Post: 29-08-2009, 13:56
    5. Holley carb
      By TATFINK in forum Stuff - FOR SALE
      Replies: 0
      Last Post: 03-06-2009, 11:09

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •