oil pressure lose or to much crankcase pressure
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline

    oil pressure lose or to much crankcase pressure

    i am very near to havin a breakdown my engine is causin me a lot of problems & all i did originally is change the cam.
    first the inlet didnt seal & it had an air leak so took the manifold of & reseal inlet it then sucked oil up into the manifold & down the exhaust what didnt help was i had timed it up 90degres out so it turfed out quite a bit of oil in the middle lane of the m25 so took it home stripped engine out did complete
    rebiuld as in new big ends new main ends new rings new valves new valve seals & yet again another new set of inlet gaskets got it running the rear maniflod seal stared leaking so stripped it off & fitted new seals with glue this time worked went out had low oil pressure so moved oil switch from under the dash to engine got good pressure to start with then dropped off went out
    sunday blew oil out of did stick tube changed back to old dipstick no leak now when i start up i have a good pressure for about 5 mins the bang back to low pressure this time its flowing out of the rear seal just dont know what to do next the only thing i didnt do when we rebuilt was trim the rear seal could this be the problem.i just dont know

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,345
    Images
    12
    Post Thanks / Like
    kapri is online now
    Oil pressure relief valve blowing off ? Too thick oil ,usually from adding Wynns etc would do this as well. Blocked PCV valve causing crankcase pressurisation?

    Where is the oil sender ? Is it after the end of the cam galleries ? Worn cam bearings can lead to low oil pressure reading while thereis actually good pressure at the bottom end (often a Chevy problem )?

    Yank V8s not my forte so just a few general thoughts

  4. #3
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    hi kapri
    checked pcv or the rattly valves in the breathers all seem ok no wear on the cam bearings the pressure switch is just above the oil filter (b/b chevy)
    but the to thick oil sounds intresting i have put in what i always have would you belive gp50 but now that you have mentioned it should i be using something like 20/50 or 14/50 diesel oil for running in.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict 35kid's Avatar
    Join Date
    Apr 2009
    Location
    up north
    Posts
    1,987
    Images
    3
    Post Thanks / Like
    35kid is offline
    GP50? that must be like treacle I would have thought that was your problem.

  7. #5
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    hi
    just tryed it with 14/40 diesel oil the oil isnt throwing out every where now just dripping so think i might have done rear seal. so when i have cooled down & walked away from the hammer i will take the engine out & replace the seal .
    but thanks for your advice it definitly seems to be the treacle like oil i had used just didnt think before i used it.

  8. #6
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,345
    Images
    12
    Post Thanks / Like
    kapri is online now
    Did the oil pressure improve as well Chris ?

  9. #7
    Official RnS Addict WB54's Avatar
    Join Date
    Apr 2009
    Location
    Herts
    Posts
    4,602
    Images
    198
    Post Thanks / Like
    WB54 is offline
    I wouldn't be so sure, thicker oil normally shows higher oil pressure I thought. 20/50's right for most cast iron V8's, some run thinner modern oils but they're old clunkers with fairly big bearing clearances compared to modern ****.

    Did you have the block honed when you rebuilt it ? did you measure the main and big end bearing running clearance, correct bearings for motor ? who installed the cam bearings, again whats your running clearance ? ring end gaps ?

    Have you run it without the breathers connected to anything ? sounds like two issues to me, I'd say oil pressure is bearing related, and potentially you've got some crankcase pressure, manifold and dipstick aren't pressurised like the oil galleries.

  10. #8
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,345
    Images
    12
    Post Thanks / Like
    kapri is online now
    Thta's what I used to think Phil, but I've had oil pump pressure relief valves blow off with 20/50 with Wynns added ( 4 pot Ford),so oil light stayed on ( end of gallery straight of pump) had me foxed for ages.
    Last edited by kapri; 11-08-2009 at 20:02.

  11. #9
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    Quote Originally Posted by kapri View Post
    Did the oil pressure improve as well Chris ?
    Quote Originally Posted by WB54 View Post
    I wouldn't be so sure, thicker oil normally shows higher oil pressure I thought. 20/50's right for most cast iron V8's, some run thinner modern oils but they're old clunkers with fairly big bearing clearances compared to modern ****.

    Did you have the block honed when you rebuilt it ? did you measure the main and big end bearing running clearance, correct bearings for motor ? who installed the cam bearings, again whats your running clearance ? ring end gaps ?

    Have you run it without the breathers connected to anything ? sounds like two issues to me, I'd say oil pressure is bearing related, and potentially you've got some crankcase pressure, manifold and dipstick aren't pressurised like the oil galleries.

    hi
    in answer to the questions the thinner oil did seem to work as it did not throw the oil everywhere out of the seal it is only dripping . so coing to remove engine & replace seal.

    didnt check bearing as when we removed the old ones they where still grey & not worn down to copper but i did measure the rings & have a 15thou gap.
    i have had a friend pop round last night (jonh tudor ) who run the lime green supercharged prostreet camero who had a quick look over it the pressure dropping problem would seem to come from the fact that the rad is blocked temp rose to 172 within 10 mins of starting & the fans were drawing cold air not warm. after switching off the fans ran on for about 5 mins then switched off then restarted a couple of mins later with 1 drawing warm air & 1 drawing cold.
    so now need to find some where that can unblock an ali rad.
    but i will get there in the end . if im at the nats you'lle now it has worked
    thanks everybody for there input it has been very helpful.

  12. #10
    capriac capriac's Avatar
    Join Date
    Jul 2009
    Location
    rayleigh essex
    Posts
    1,810
    Images
    388
    Post Thanks / Like
    capriac is offline
    hope to see you there !

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Rad cap pressure options?
      By Kustom Jim in forum Tech Discussion
      Replies: 1
      Last Post: 14-05-2010, 17:59
    2. rad cap pressure?
      By jack earls in forum Tech Discussion
      Replies: 8
      Last Post: 01-04-2010, 09:33
    3. Under pressure
      By Britdragster in forum Tech Discussion
      Replies: 7
      Last Post: 19-03-2010, 20:15
    4. Petrol Pressure washer
      By v8 jago in forum Stuff - FOR SALE
      Replies: 0
      Last Post: 06-03-2010, 09:25
    5. V6 oil pressure problem
      By Tiddytime in forum Tech Discussion
      Replies: 5
      Last Post: 22-11-2009, 20:33

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •