performer rpm cam
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline

    performer rpm cam

    does anybody know if a performer rpm cam has a rough idle on tick over or a smooth idle ive just fitted one & i cant get it to stop souding like a pro mod.
    i have changed inlet gaskets & carb& im still having a job tuning.i am now at the point of giving up so if anybody might be able to throw some idea my way as to what to look for before i go completly bald.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Carburation 'sucks' Roscobbc's Avatar
    Join Date
    Apr 2009
    Location
    South West Essex
    Posts
    4,093
    Images
    14
    Post Thanks / Like
    Roscobbc is offline
    Have you tried advancing static timing?

  4. #3
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    i have advanced timing up to 16 b4 this is the only way we can get it to idle
    this all started with what we think was an air leak in the manifold because when the temp reached 200 it would rev to 1700 so removed inlet resealed gaskets but still had air leak seemed to be intermitant as you could here it every time the engine ran rough but now not sure where to go next.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Exceeded sell by date Plumpcars's Avatar
    Join Date
    Apr 2009
    Location
    London Heathrowish!
    Posts
    7,721
    Images
    46
    Post Thanks / Like
    Plumpcars is offline
    Have you rebuilt the heads? Had them skimmed? If so the manifold may not be seating correctly and would give the symptoms you describe.

  7. #5

    Join Date
    Apr 2009
    Posts
    489
    Images
    0
    Post Thanks / Like
    langy is offline
    I use the RPM cam most of the time in SBF's and find them slightly lumpy but tickover quite well, what engine do you have ???, Sounds like timing or a vacuum leak.


    Quote Originally Posted by chrismk4 View Post
    i have advanced timing up to 16 b4 this is the only way we can get it to idle
    this all started with what we think was an air leak in the manifold because when the temp reached 200 it would rev to 1700 so removed inlet resealed gaskets but still had air leak seemed to be intermitant as you could here it every time the engine ran rough but now not sure where to go next.

  8. #6
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    Quote Originally Posted by Plumpcars View Post
    Have you rebuilt the heads? Had them skimmed? If so the manifold may not be seating correctly and would give the symptoms you describe.
    Quote Originally Posted by langy View Post
    I use the RPM cam most of the time in SBF's and find them slightly lumpy but tickover quite well, what engine do you have ???, Sounds like timing or a vacuum leak.
    did have the heads off but only to have valve stems turnred down for double springs. engine is 396 b/b chevy with closed chamber oval port heads originaly from 66 chevy chevelle.

  9. #7
    Exceeded sell by date Plumpcars's Avatar
    Join Date
    Apr 2009
    Location
    London Heathrowish!
    Posts
    7,721
    Images
    46
    Post Thanks / Like
    Plumpcars is offline
    Could it be the cam giving a lower vacuum and maybe upsetting the power valve? You need to know the vacuum at idle and tune power valve accordingly.

  10. #8
    prostreet enthusiast
    Join Date
    Apr 2009
    Location
    bromley kent
    Posts
    195
    Images
    40
    Post Thanks / Like
    chris-461 is offline
    already done that cam pulling about 10 so changed power valve to 4.5 as advised by man at customville.
    was wondering if valves were to tight would this make it idle rough & have a loud crackle trough the exhaust.

  11. #9
    Official RnS Addict Zody's Avatar
    Join Date
    May 2009
    Location
    Sussex
    Posts
    1,769
    Images
    3
    Post Thanks / Like
    Images
    3
    Zody is offline
    I have come across a similer problem before, my mate fitted a new cam & timing gears in his 454, ran like a bag of poo on tick over ?

    I decided to pull the timing cover, and found the bottom gear was in the wrong posistion, as the crank gear had 3 x posistions, he had set one that looked like a "O" but turned out to be a oblong square ! the gear line up was close to 2 x teeth out ...

    I'm not saying yours is the same .... but worth a check ????
    Last edited by Zody; 18-06-2009 at 09:46.
    The car is open, the keys are under the dog !

  12. #10
    Dragging not Bragging vince-305's Avatar
    Join Date
    Apr 2009
    Location
    S.E London
    Posts
    5,697
    Images
    510
    Post Thanks / Like
    vince-305 is offline
    He's replaced the chain with gears and has double checked the position and they are correct
    Bit'z 'N' Piece's
    Ford consul mk2 chevy powered highrider

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Edelbrock Performer manifold Rover V8
      By john64 in forum Stuff - FOR SALE
      Replies: 2
      Last Post: 05-05-2010, 12:15
    2. Edelbrock performer 750 cfm carb
      By trevd in forum Stuff - FOR SALE
      Replies: 1
      Last Post: 15-01-2010, 18:52
    3. Swap: Performer manifold for SBC Flywheel
      By Paul Y in forum Stuff - FOR SALE
      Replies: 6
      Last Post: 02-11-2009, 09:41

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •