Rolling road. - Page 3
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 21 to 30 of 50

Thread: Rolling road.

  1. #21
    My name is Martin 30psi's Avatar
    Join Date
    Apr 2009
    Location
    Hornchurch, Essex
    Posts
    2,544
    Images
    9
    Post Thanks / Like
    30psi is offline
    Well it revs ok in 1st and 2nd doesn't it? Otherwise I'd suggest valve springs

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #22
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,652
    Images
    12
    Post Thanks / Like
    kapri is offline
    Revs out fine in 1st and 2nd. Cam is a kit with matched ,pads ( followers ) springs and retainers , it's only the box shifting ,at 6000 !!, that stops it revving . That's why it's weird about it only being in top so.....


    I'm leaning towards fuelling now ,you can't make power without fuel and air. I've had similar in the past where you could accelerate quickly through 1/2/3 but when you hit 4th it would die. Trouble then was traced to a pump that couldn't keep up with the amount of fuel being used.

    I also had this on my 1776 Beetle lump , pulled like a train but on a rolling road it leaned right out in top , fresh pump and regulator fixed that .
    I'm thinking that the AFR readings although fine are possibly lower than they should be due to fuel starvation? Who knows ? Fuel pump should help with that otherwise I need to check the mixture enrichment set up in the Weber that only kicks in at high velocity.
    Last edited by kapri; 21-08-2009 at 15:51.

  4. #23
    My name is Martin 30psi's Avatar
    Join Date
    Apr 2009
    Location
    Hornchurch, Essex
    Posts
    2,544
    Images
    9
    Post Thanks / Like
    30psi is offline
    As I said before, try to find someone with a wideband that you can make use of.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #24
    In-between 1932 & 1951 DeuceTudor's Avatar
    Join Date
    May 2009
    Location
    West Sussex
    Posts
    333
    Images
    0
    Post Thanks / Like
    DeuceTudor is offline
    Kev .many years ago i had a 2.0ltr capri with the same problem you've got on the APU ,turned out to be the fuel pump ,changed for a new one plumbed direct to the carb and was told to blank off the return line ,pulled like a train after that .
    "If it was that easy,everybody would do it"

  7. #25
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,652
    Images
    12
    Post Thanks / Like
    kapri is offline
    Tomorrows job Matt Along with changing the timing plate and retiming. I may pop by if I get it done in decent time.

  8. #26
    In-between 1932 & 1951 DeuceTudor's Avatar
    Join Date
    May 2009
    Location
    West Sussex
    Posts
    333
    Images
    0
    Post Thanks / Like
    DeuceTudor is offline
    Hi Kev ,thought of something else in the wee small hours ,check the action and length of the fuel pump push rod ,i'll dig out my old work shop manual i'm sure its got the spec's in there.
    "If it was that easy,everybody would do it"

  9. #27
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,652
    Images
    12
    Post Thanks / Like
    kapri is offline
    You are another where the little conundrums just roll around at teh back of your mind then ?

    I've replaced the timing plate and irt was timed correctly first time I've just also advanced it one tooth theh tried it and also retarded one tooth ( 9.47 degrees) and both ways it runs like a sack.

    Just changed the fuel pump over and checked the pushrod length 49.90mm if you find the manual to check. I haven't tried it yet as my back is crucifying me so come to sit down and ease it so I can refit the hood to take it for a trial run.

  10. #28
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,652
    Images
    12
    Post Thanks / Like
    kapri is offline
    I seem to have spent forever messing with jets today ,weakening the primary and richening the secondary none which made any improvement. It appears that the high speed enrichment system was also blocked. Cleaned that and STILL no difference.

    When I crack the throttle hard at standstill I get an earsplitting crack and about 4 inches of fuel reversion ( only from secondary choke ) so my best guess is still cam timing. Guess I'll have to wait until the vernier pulley turns up now.


    EDIT . Thinking about it the last time I saw reversion like this was on a twin 40 carbed 1776 Beetle lump, that wouldn't rev cleanly either. That turned out to the exhaust manifold had a plate with holes through it at the end of the manifold and before the silencer. Drilled that out and it revved cleanly . Mmmmm...think if the vernier doesn't sort it then new box next ?
    Last edited by kapri; 22-08-2009 at 18:28.

  11. #29
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,652
    Images
    12
    Post Thanks / Like
    kapri is offline
    Well, I've pulled of the exhaust system ...all clear The only silencer is a straight through oval and although the glass pack is loose in the can the whole system is clear ( rodded it through just to be sure. Fired it up without the exhaust and still flat .

    Running out of options here .

  12. #30
    In-between 1932 & 1951 DeuceTudor's Avatar
    Join Date
    May 2009
    Location
    West Sussex
    Posts
    333
    Images
    0
    Post Thanks / Like
    DeuceTudor is offline
    Hi Kev, Can't find worshop manual at the mo ,misses tidied up the the loft and can't remember which box she put it in (bless her)!! .I had another thought have you checked the TDC is at TDC had a problem on a sierra once where the crank pulley notch was way out ?

    (above not teaching you to suck eggs) could pop around if you want two heads better than one and all that ,had lots of tuned Pinto's in the past might see something ??
    Last edited by DeuceTudor; 24-08-2009 at 10:55.
    "If it was that easy,everybody would do it"

+ Reply to Thread
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. rolling road advice
      By dal2litrefrogeye in forum Chat
      Replies: 5
      Last Post: 11-05-2010, 20:46
    2. favourite road or place on that road
      By spider in forum On Topic
      Replies: 31
      Last Post: 16-02-2010, 15:36
    3. Dyno vs Rolling road
      By vince-305 in forum Tech Discussion
      Replies: 6
      Last Post: 26-01-2010, 23:24
    4. Replies: 8
      Last Post: 07-10-2009, 21:46

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •