rover v8 ignition module
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Official RnS Addict chop top mk2's Avatar
    Join Date
    May 2012
    Location
    lancashire
    Posts
    1,214
    Images
    2195
    Post Thanks / Like
    chop top mk2 is offline

    rover v8 ignition module

    hi all,
    i wonder if some one has any idea as to why my ignition keeps blowing modules. car ran fine for about a year and a half and now it keeps blowing the modules if its run for more than a few minutes.
    its a power spark dizzy off ebay. its driving me nuts know.

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Rod'a'holic rodbuilder's Avatar
    Join Date
    Apr 2009
    Location
    Glastonbury
    Posts
    1,019
    Images
    721
    Post Thanks / Like
    rodbuilder is offline
    You need a low resistance coil, less than 1.4 ohms, over that will blow the module and/or the magnetic pick up. maybe not straight away but far from home in the rain usually.

    Modern made in China ones are less resilient than old ones hence the issue now.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •