rover v8 twin turbo loses power under load
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    Rods 'n' Sods Junkie
    Join Date
    Mar 2012
    Location
    leed uk
    Posts
    365
    Images
    28
    Post Thanks / Like
    mcmental is offline

    rover v8 twin turbo loses power under load

    hmmm more questions now folks, rover 3.5 v8 twin draw thru turbos running through twin SU carbs, car sits and ticks over lovely but as soon as i slip it into gear (auto 3 speed) the revs drop down and nearly stall, i can drive it but theres no power what so ever, if i blip the pedal it revs up and wants to set off but then it bogs down straight away, fuel regulator is set at 5psi at the minute.

    driving me potty is this as i need the car running for my wedding

    please help

    cheers
    chris

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict
    Join Date
    Oct 2012
    Location
    surrey
    Posts
    622
    Images
    2
    Post Thanks / Like
    neil still building it is offline
    you do have oil in the dashpots.....just thought i'd ask!
    sounds very lean to be doing this
    neil

  4. #3
    Rods 'n' Sods Junkie
    Join Date
    Mar 2012
    Location
    leed uk
    Posts
    365
    Images
    28
    Post Thanks / Like
    mcmental is offline
    if its in D R 2 or 1 it loses power, neutral is fine though.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict choppedblownpop's Avatar
    Join Date
    Dec 2009
    Location
    kent
    Posts
    2,879
    Images
    0
    Post Thanks / Like
    choppedblownpop is offline
    Vacuum hoses connected properly ?
    Does the auto have a vacuum supply ? (I don't know,I'm a manual)

  7. #5
    Rods 'n' Sods Junkie
    Join Date
    Mar 2012
    Location
    leed uk
    Posts
    365
    Images
    28
    Post Thanks / Like
    mcmental is offline
    im going to check the vacuum hoses now, theres also 1 going to the brake servo

  8. #6
    Rods 'n' Sods Junkie
    Join Date
    Mar 2012
    Location
    leed uk
    Posts
    365
    Images
    28
    Post Thanks / Like
    mcmental is offline
    do the vac hoses go to the inlet manifold?

  9. #7
    Official RnS Addict choppedblownpop's Avatar
    Join Date
    Dec 2009
    Location
    kent
    Posts
    2,879
    Images
    0
    Post Thanks / Like
    choppedblownpop is offline

  10. #8
    Official RnS Addict
    Join Date
    Oct 2012
    Location
    surrey
    Posts
    622
    Images
    2
    Post Thanks / Like
    neil still building it is offline
    its not under load when in neutral though is it...?did you check the oils level with the top of the su piston tube
    have you had it running correctly at all,or a new build?
    ignition leads bad?/plugs slightly fouled
    neil

  11. #9
    Official RnS Addict
    Join Date
    Aug 2011
    Location
    surrey
    Posts
    1,662
    Images
    19
    Post Thanks / Like
    robo1 is offline
    Now the engine has been turbo charged all the vacuum stuff that went on the inlet will have to be moved outboard to the stubs between the carbs and the turbo. As soon as you get on the gas the manifold gets pressurized and you will be left with no brake servo or crankcase vac.

    Bob

  12. #10
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,073
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    needle profiles need changing ,prob also need stronger springs .is it showing lean on stumble ?

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Mk2 Cortina Lutus twin turbo V8
      By alan in forum The Garage
      Replies: 164
      Last Post: 25-12-2015, 14:10
    2. Twin Turbo 4.0 Rover V8 :D
      By Monster_Moggy in forum Stuff - FOR SALE
      Replies: 4
      Last Post: 15-04-2012, 15:10
    3. Rover sd1 twin plenum injection complete set-up
      By Willys V8 in forum Stuff - FOR SALE
      Replies: 0
      Last Post: 28-02-2011, 18:36
    4. 1956 Chevrolet Bel Air – Twin Turbo Street Eater – 31
      By NoJive 55 in forum Tri Chevys, Spirit Of the Fifties and the Tuck Up Squad boys
      Replies: 0
      Last Post: 12-12-2010, 10:03
    5. BBF twin turbo set up
      By fozwanger in forum Stuff - FOR SALE
      Replies: 5
      Last Post: 03-07-2010, 21:35

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •