someone help this young girl fix her car
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    Rods 'n' Sods Junkie andy's Avatar
    Join Date
    Apr 2009
    Location
    edinburgh scotland
    Posts
    410
    Images
    74
    Post Thanks / Like
    andy is offline

    someone help this young girl fix her car

    Had the camaro (86 5.o v out a few weeks ago for a bit rip,which it hadn't had for literally a year or so!! all was fine till heading home and the srvice eng light flickered, as it did the engine seemed 2 choke/lose power and it felt like it wanted 2 die, this was at about 10mph, then it cut out, started up 1st time and got me home which was less than a mile away thankfully, kind of kangarood all way home with light flashing intermittantly.
    did a error code check following night after leaving it to sit and showed up no codes and ran fine the other 2 times i had it out, however i took it out yesterday and gave it one boot on the way home an it started it's crap again, i pulled over an turned it off for a few mins but was still same all way home, then when got in would'nt hold a rev, was a bit spluttery, would say a misfire but is kinda hard to tell? too me anyway, cuts out if not on the gas and its sad there since how often do u reckon plugs and oil need changes it sometimes doesnt move for 4-5 ays at a time, could this be part of the prob? the fuel filter was so corroded 2mnths back the garage 'bypassed' it? as thts where the leak was but it runs fine untill caned? any suggestions wud be appreciated, thanx x

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict vin likes diesel's Avatar
    Join Date
    Apr 2009
    Location
    London
    Posts
    2,801
    Images
    1527
    Post Thanks / Like
    vin likes diesel is offline
    No fuelfilter could cause no end of problems
    Pro Street Escort... MOT ready.
    Hug Street Morris Oxford mo.... unfinished, on its tenth set of wheels
    Custom truck ..MOT ready
    Dinner ....finished

  4. #3
    Official RnS Addict mikeyboy's Avatar
    Join Date
    Apr 2009
    Location
    San Diego.Calif USA
    Posts
    2,422
    Images
    209
    Post Thanks / Like
    mikeyboy is offline
    shoulda put a new fuel filter on it.
    There's no replacement for displacement.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    matt black is for chalk lil miss petrolhead's Avatar
    Join Date
    Dec 2009
    Location
    north lincs
    Posts
    640
    Images
    228
    Post Thanks / Like
    lil miss petrolhead is offline
    if the fuel filter was so badly corroded, theres every chance that theres crap in the rest of the fuel system,i would suggest a stripdown ,thorough clean, check the tank for scale/crud,check any steel fuel lines for corrosion,check any rubber fuel lines aswell as they can deteriate and you wind up with small specs of rubber blockin jets/injectors. then put a new fuel filter on,probably get a different garage to do the work, as the numpty that bybassed the filter is clearly a bodge artist.

  7. #5
    I'm a newbie !
    Join Date
    Dec 2011
    Location
    scotland
    Posts
    19
    Images
    0
    Post Thanks / Like
    amyiroc is offline
    hey guys finally got registerd, thanx 4 replys, i gave the garage a new filter to fit an 'apparently' was to corroded to get on, it had new fuel lines last year, how wud i go about giving it a fuel clear out without to much stripping? pretty crap for garages that specialise in real cars around here ;(

  8. #6
    Official RnS Addict Slamera63's Avatar
    Join Date
    Feb 2010
    Location
    Hull, Yorkshire
    Posts
    1,985
    Images
    3
    Post Thanks / Like
    Slamera63 is offline
    Was the new fuel lines put on by the same garage?, as already stated find a different garage cos this thicko could have caused you more serious trouble, if crap has got through to the injectors you've got a bigger problem as the injectors need to be cleaned, a bill that in my opinion should be paid for by the cowboys who by-passed your fuel filter. You dont need a "speacialist" garage to do a job like changing a fuel filter, this is just basic stuff.

  9. #7
    matt black is for chalk lil miss petrolhead's Avatar
    Join Date
    Dec 2009
    Location
    north lincs
    Posts
    640
    Images
    228
    Post Thanks / Like
    lil miss petrolhead is offline

  10. #8
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    23,579
    Images
    12
    Post Thanks / Like
    kapri is online now
    New fuel filter back inline , then put some injection cleaner , available from Halford ( if you must! ), into your tank and run. This will help clean any light sediment from the injector tips. Problem may still be there in which case it'll need injectors removing and ulrasonically cleaning. Don't refit them until you are SURE the rest of the system is clean or it will be a total waste of time and money.

  11. #9
    Official RnS Addict lambretta_ash's Avatar
    Join Date
    Aug 2011
    Location
    birmingham, quinton/oldbury
    Posts
    1,196
    Images
    287
    Post Thanks / Like
    lambretta_ash is offline
    Quote Originally Posted by amyiroc View Post
    hey guys finally got registerd, thanx 4 replys, i gave the garage a new filter to fit an 'apparently' was to corroded to get on, it had new fuel lines last year, how wud i go about giving it a fuel clear out without to much stripping? pretty crap for garages that specialise in real cars around here ;(
    get some spanners and start playing girl
    well u can unscrew your fuel sender and look thru there for the tank part
    by what do i know i drive a 4inline a series engine none of these sexy v8 v mmmmmmmmmmm sorry gotta clean lmao

  12. #10
    Rods 'n' Sods Junkie
    Join Date
    Dec 2010
    Location
    Tokyo japan
    Posts
    175
    Images
    32
    Post Thanks / Like
    steven is offline
    I had the same problem afew months back it turned out to be water in the system.
    Ran fine and then cut out, once the fuel settled out it ran fine until it mixed again.
    All this was on an old v8 rover

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Replies: 2
      Last Post: 11-11-2010, 21:29
    2. Replies: 6
      Last Post: 08-08-2010, 18:31
    3. help..i need to get my car on a car ramp
      By jimo62 in forum Tech Discussion
      Replies: 2
      Last Post: 15-06-2010, 14:21
    4. Help - two vehicles to fix!
      By zephyr in forum Tech Discussion
      Replies: 2
      Last Post: 15-04-2010, 16:00
    5. Can someone help me...???
      By bigyellataxi in forum Chat
      Replies: 6
      Last Post: 23-04-2009, 17:31

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •