zodi troubles again.
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  0
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Rods 'n' Sods Junkie XskotyX's Avatar
    Join Date
    Jul 2011
    Location
    Halesworth
    Posts
    478
    Images
    3
    Post Thanks / Like
    XskotyX is offline

    zodi troubles again.

    Right.... im just looking for some advise here as im getting baffled and quite annoyed now haha...
    Some may remember I got worried as mg zodi was breathing... I was advised to keep using it itl be fine and it is... iv done over 5000 miles now with no problem, hasnt burnt a drop of oil or water and the breathing hasnt gotten heavier. I bought another engine to do up ready... but this turned out to be a junker so im on the look for another spare at the minute....

    anyways back to the issue.... I think its fuelling problem. Sometimes when I go to start her she seems flooded... some times wont turn over at all like a flat battery then will suddenly unlock and turn over... I think the starter is on its way out aswell so not a help haha.... and sometimes when I start her she spins over and over and over then suddenly burst into life but plumes smoke out that stinks of petrol.... mostly she'll start okay but then is really lumpy like not firing on all 6 till I rev her and the lumpyness gets less untill its dead smooth.... now she pulls like a train still but then everynow and then has a little hicup...
    I bought a new carb and rebuild kit and fitted that... but then I noticed it was dripping fuel into the carb all the time so I wrapped some plumbers tape stuff round the threaded part of the jet as this seemed loose... this did make the problem alot better. But still has these issues... im thinking of maybe putting all the new parts into my old carb body next incase this carb is just ****.

    I just dunno what im missing??? Could it be head gasket on its way out?
    "she may be rusted iron, but to me she's solid gold"

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    richard rawlplug Torment's Avatar
    Join Date
    Apr 2009
    Location
    nottafukinchancingham
    Posts
    7,757
    Images
    56
    Post Thanks / Like
    Torment is offline
    float level ok in the carb..???

    (not sure which carb you have by the way)


    The Oddlot Drag Racing Team...havin fun is usual
    57 bel air wagon
    540cui altered.
    your not drunk enough if you can lie on the floor without holding on..

  4. #3
    Semi Proffessional Prat sidspop's Avatar
    Join Date
    Apr 2009
    Location
    YamYam central
    Posts
    3,489
    Images
    453
    Post Thanks / Like
    Images
    74
    sidspop is offline
    Ok chap, I am presuming straight six, so it's the same as a Thames but a couple of extra cylinders glued on the end. Theories are the same.
    If it were me, i would attack it in a logical manner.

    Compression check all cylinders, amke sure between 10% of each other.
    Check plugs, leads, timing etc, and make sure they are correct. Use NGK BPR6ES plugs if they need changing, plug gap 30 thou.
    If it has the hockey stick exhaust, see what you can do to isolate heat from exhaust to bottom of carb. On mine I fitted a bit of a sheet of asbestos type stuff to act as a heatshield.

    Other stuff to consider. Problems starting.....extra earth from battery straight to engine block, bell housing bolts are ideal.
    Ensure good earth to distributor. Do you have electronic ignition? Suggest you fit it, Simonbbc on ebay does kit, they work.
    Also check two posi headed screws in distributor, pop the cap off, and the two that hold the plate to the body of the dizzy. I have known them intermittant.

    Give us some spec on the setup.
    Its either you lay down and die or you get on with your shit till you do!!!!! No Other Way Around It. One or the other. Don't worry about being forgotten, you will. Rather worry about in how long it will take for you to be forgotten, bro.

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict cozmic's Avatar
    Join Date
    Dec 2009
    Location
    isle of wight
    Posts
    1,079
    Images
    0
    Post Thanks / Like
    cozmic is offline
    Hi assuming its still on a zenith downdraft carb if so there should be an o ring on the main jet if this is missing/ damaged it will leak fuel as described. Yes it does sound like the starter could be on the way out as what you describe is identical to how my old mk3 zodiac behaved (I ended up fitting a high torque starter ), as sidspop said check the distributor and timing as I found mine to be quite sensitive to points condition and timing. Simon BBC on ebay electronic ignition units are very good but if your feeling flush they also do brand new purpose built lucas electronic distributors to fit your engine ,I fitted one to my mk3, I think they cost about £90 it totallt transformed the old zodiac.
    Good luck sorting your car

  7. #5
    Official RnS Addict
    Join Date
    Apr 2009
    Location
    .
    Posts
    1,317
    Images
    0
    Post Thanks / Like
    Neil G is offline
    It might be worth checking out, but if you used ptfe tape on the jet i expect the fuels eaten it away and you may have a bit of tape blocking something.

  8. #6
    Semi Proffessional Prat sidspop's Avatar
    Join Date
    Apr 2009
    Location
    YamYam central
    Posts
    3,489
    Images
    453
    Post Thanks / Like
    Images
    74
    sidspop is offline
    Quote Originally Posted by XskotyX;1062201
    .. some times wont turn over at all like a flat battery then will suddenly unlock and turn over...[COLOR="#FF0000"
    Bad earth then catching with engine vibration[/COLOR] I think the starter is on its way out aswell so not a help haha.Bad earth?... and sometimes when I start her she spins over and over and over no spark, possibly due to bad earth????then suddenly burst into life but plumes smoke out that stinks of petrol.cus carb is working but spark isn't, due to.......are you getting a pattern here?... mostly she'll start okay but then is really lumpy like not firing on all 6 till I rev her and the lumpyness gets less untill its dead smooth.... now she pulls like a train still but then everynow and then has a little hicup...
    Anybody agree?
    Last edited by sidspop; 25-09-2013 at 21:44.
    Its either you lay down and die or you get on with your shit till you do!!!!! No Other Way Around It. One or the other. Don't worry about being forgotten, you will. Rather worry about in how long it will take for you to be forgotten, bro.

  9. #7
    Rods 'n' Sods Junkie XskotyX's Avatar
    Join Date
    Jul 2011
    Location
    Halesworth
    Posts
    478
    Images
    3
    Post Thanks / Like
    XskotyX is offline
    Hi thanks for the replies... sorry I didnt put any details about the car last night, wasnt really thinking straight. Yep she totally standard and running the standard zenith carb.... only non standard part is I bought the proper converted electronic distributor.
    Hmmmm I will look into the earthing theory sounds logical now I think.... also I noticed that sometimes when turning the engine over the bar that opperates the throttle on the carb gets really hot!!!! But nothing else does so im sure something is shorting out?? But the only thing that made me think its fuel is because the car has a bad smell when running... but I cant really describe the smell.
    "she may be rusted iron, but to me she's solid gold"

  10. #8
    Rods 'n' Sods Junkie It's Frothy Man's Avatar
    Join Date
    Sep 2010
    Location
    Portsmouth
    Posts
    215
    Images
    1
    Post Thanks / Like
    It's Frothy Man is offline
    Had the same thing on my Cresta went from a good starter to a non starter over a few weeks. The throttle linkage was also getting hot although I did not notice but in the dark I could see it was arcing out from the linkage to the manifold!!!

    I replaced the earth from the engine to chassis and battery to chassis and gave the mounts a damn good clean. Starts on the button now and no arcing. Worth a try.
    Last edited by It's Frothy Man; 26-09-2013 at 21:03.

  11. #9
    Off the Xmas card list kapri's Avatar
    Join Date
    Apr 2009
    Location
    Portsmouth
    Posts
    22,831
    Images
    12
    Post Thanks / Like
    kapri is offline
    Quote Originally Posted by XskotyX View Post
    Hi thanks for the replies... sorry I didnt put any details about the car last night, wasnt really thinking straight. Yep she totally standard and running the standard zenith carb.... only non standard part is I bought the proper converted electronic distributor.
    Hmmmm I will look into the earthing theory sounds logical now I think.... also I noticed that sometimes when turning the engine over the bar that opperates the throttle on the carb gets really hot!!!! But nothing else does so im sure something is shorting out?? But the only thing that made me think its fuel is because the car has a bad smell when running... but I cant really describe the smell.
    Sounds like you are missing an engine earth if the rod is getting hot . Plus too advanced timing can give the symptoms of bad battery . You may not have adjusted the timing but if the bob weights stick they will leave the timing over advanced. Take the dizzy cap off and check there is movement at the rotor.

    EDIT Must read ALL replies before posting ! The other thing is that woven wire earth leads are crap , replace with proper insulated copper one.
    Last edited by kapri; 26-09-2013 at 07:24.

  12. #10
    Rods 'n' Sods Junkie XskotyX's Avatar
    Join Date
    Jul 2011
    Location
    Halesworth
    Posts
    478
    Images
    3
    Post Thanks / Like
    XskotyX is offline
    Right so I think iv sorted the starter motor problem... I stripped tge motor down cleaned it and put it back together I took all the earth cables off cleaned them and sprayed them with contact spray stuff... starter is working oerfect now, so musta been an earth problem.. next I moved onto the dizzy... started adjusting the timing by ear... but then decided to try with the gun... set it up with the gun it idled perfect then as soon as I went to rev her she just splattered banged and stalled out!! So I looked at the vacuum advance thingy and relised it was all loose!!! I took the dizzy out and pulled it apart put it back to gether proper and also changed the vacuum pipe for proper vacuum tube instead of WASHER PUMP pipe!!!!! Now it runs smooth as anything again!!!
    Next onto the carb... I took the jet out and removed the plumbers tape that as one'a you guys said it had disintegrated! I just screwed the jet back in for now... but gonna rebuild my old carb body next...

    now shes still got the issue of when I go to restart her after about 5 mins she'll turn over loads then splutter into life firinv on like 4 and plooming petrolly smoke... but im hoping this is just because the carb is now dripping feul into the inlet manifold while its turned off and it takes a while to burn the excess petrol when starting... so hopefully putting my old carb back on will cure this... thanks so much for your helpfull input guys... and anymore advise would be gladly welcomed..
    Cheers.
    "she may be rusted iron, but to me she's solid gold"

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Teething troubles....
      By MR1958CADILLAC in forum Chat
      Replies: 17
      Last Post: 02-08-2009, 00:38
    2. vin likes diesel feels wanted again
      By vin likes diesel in forum Who are ya ??
      Replies: 13
      Last Post: 27-04-2009, 15:07
    3. It's that bloody striper again !
      By tootall in forum Who are ya ??
      Replies: 11
      Last Post: 24-04-2009, 19:55
    4. mk1 Zeph/Zodi/Consul NSF NSR OSR doors
      By bigyellataxi in forum Stuff - FOR SALE
      Replies: 0
      Last Post: 23-04-2009, 21:23
    5. It's me again...
      By Flat Ernie in forum Who are ya ??
      Replies: 10
      Last Post: 23-04-2009, 04:13

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •