poor running 350
Have an account? Register

Forgot your password?

Forgot your username?

 
Likes Likes:  1
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    Official RnS Addict
    Join Date
    Apr 2009
    Location
    nowhere
    Posts
    6,518
    Images
    2241
    Post Thanks / Like
    nobody is offline

    poor running 350

    had my car out for a blat at the weekend.
    always starts and runs fine. stock 350 with an edelbrock 500.

    after being out,started car up and it started to run rough straightaway. seams like the revs on tickover have dropped a bit,so on tickover it wont energise the alternator and wants to stall in gear.

    turning up the tickover screw brings the revs up enough to kick in the charging system,but the car feels very lumpy,compared to really smooth ,how it was befor



    any pointers as to what to check

    thanks
    Rod/custom/drag build profiles:
    Mini | Pop | Porker | Trike | Morris 8

    | 48 chevy coupe | ford f100 | tube chassis,d pop

  2. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  3. #2
    Official RnS Addict timbo56's Avatar
    Join Date
    May 2016
    Location
    S E London
    Posts
    848
    Images
    22
    Post Thanks / Like
    timbo56 is offline
    Plugs fouled, **** in the carb, choke stuck closed, coil. Does it have points or electronic ign?

  4. #3
    Rods 'n' Sods Junkie
    Join Date
    May 2015
    Location
    Birmingham
    Posts
    307
    Images
    2
    Post Thanks / Like
    drseg is offline
    sounding lumpy suspect not all cyls are firing maybe run it taking one lead off at a time see if you can work out which?

  5. Remove Advertisements
    RodsnSods.co.uk
    Advertisements
     

  6. #4
    Official RnS Addict
    Join Date
    Apr 2009
    Location
    nowhere
    Posts
    6,518
    Images
    2241
    Post Thanks / Like
    nobody is offline
    its got msd electronic ignition.
    Rod/custom/drag build profiles:
    Mini | Pop | Porker | Trike | Morris 8

    | 48 chevy coupe | ford f100 | tube chassis,d pop

  7. #5
    Official RnS Addict
    Join Date
    Apr 2009
    Location
    nowhere
    Posts
    6,518
    Images
    2241
    Post Thanks / Like
    nobody is offline
    ive had carb issues befor,a long time back when the car sat around for a year or so not being used.the fuel had gone jelly like inside the carb.

    i use this car once a week,so its not out of date fuel.

    i have a good filter.would that being gunked up cause issues. only ask as the fuel pump,a holley,seams quite noicy compared to normal
    Rod/custom/drag build profiles:
    Mini | Pop | Porker | Trike | Morris 8

    | 48 chevy coupe | ford f100 | tube chassis,d pop

  8. #6
    Forum Sponsor RAYS CLASSICS.COM's Avatar
    Join Date
    Apr 2010
    Location
    san carlos california
    Posts
    3,146
    Images
    6460
    Post Thanks / Like
    RAYS CLASSICS.COM is offline
    Sounds like the carb is loading up ,as suggested earlier check the chokes not stuck after that ,pull one lead at a time .

  9. #7
    Official RnS Addict
    Join Date
    Apr 2009
    Location
    nowhere
    Posts
    6,518
    Images
    2241
    Post Thanks / Like
    nobody is offline
    electric choke.

    if it was stuck closed,wouldnt the engine start running better once it had warmed up. this was running rough for a good hour
    Rod/custom/drag build profiles:
    Mini | Pop | Porker | Trike | Morris 8

    | 48 chevy coupe | ford f100 | tube chassis,d pop

  10. #8
    Forum Sponsor RAYS CLASSICS.COM's Avatar
    Join Date
    Apr 2010
    Location
    san carlos california
    Posts
    3,146
    Images
    6460
    Post Thanks / Like
    RAYS CLASSICS.COM is offline
    in that case i,d be looking at electrical,, pull one lead at a time see if you can isolate it to a particular cylinder or maybe a compression test might tell you something , good luck i hate that kind of niggly **** at least if its making noises you can generally work out where its coming from .

  11. #9
    Official RnS Addict ivanhoew's Avatar
    Join Date
    Feb 2013
    Location
    uranus
    Posts
    2,050
    Images
    3
    Post Thanks / Like
    ivanhoew is offline
    run it at night to see if theres any sparking ?
    Bicester scramble ,Medusa enjoyed the trip.https://www.youtube.com/watch?v=Q-7I7-nA19U

  12. #10
    Stroker Kustom Jim's Avatar
    Join Date
    Apr 2009
    Location
    Bath
    Posts
    4,757
    Images
    2617
    Post Thanks / Like
    Kustom Jim is offline
    Maybe seen as the revs have dropped, apart from a miss or summat, what about an air leak as it responds a bit winding it up!?
    I've had MSDs crap out before but tend to just create poor starting but run ok after, anyhoo if it's easy to get to, a quick test to put the thing out ya mind...
    https://www.holley.com/support/troub...ng_techniques/

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Where you live, Town\City\County etc.

Please enter your full name
This field cannot be edited once it has been completed other than via contacting the site admin. Please make sure the information is correct first time.

Log-in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Bookmarks

    Posting Permissions

    • You may post new threads
    • You may post replies
    • You may not post attachments
    • You may not edit your posts
    •