Rods 'n' Sods - UK Hot Rod & Street Rod Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Howdy I'm having probs with my essex v6 , what happens is it starts ok but if I've been driving it for a bit and stop ,when I go to fire it up again it won't catch like it's flooded or summat but if I leave it for a while 30mins or so it starts fine.
I've had weber carb stripped and serviced it's got electronic ignition, fella that does lot of work on it is stumped and I'm no mechanic ,anyone any ideas?
 

·
Premium Member
Joined
·
15,123 Posts
Could it be fuel evaporation? I know those Essex's do run quite hot.[/QUOTE
that's my first thought, as far as the fuel return kev mentioned i've had essex v6's with and without a return and never had issues either way.
has the car got an electric fuel pump or mechanical? if electric that rules out evaporation as it'd prime straight away. has it got auto or manual choke. have you checked that it's not sticking partially on which would do this.
 

·
Premium Member
Joined
·
5,698 Posts
Howdy I'm having probs with my essex v6 , what happens is it starts ok but if I've been driving it for a bit and stop ,when I go to fire it up again it won't catch like it's flooded or summat but if I leave it for a while 30mins or so it starts fine.
I've had weber carb stripped and serviced it's got electronic ignition, fella that does lot of work on it is stumped and I'm no mechanic ,anyone any ideas?
Is that you Del???

As Kev says has it got provision for a fuel return on the carb?? Look for a bolt or hose with bolt above the fuel inlet, if it has I'd fit a return, as it helped mine no end...

I'm in MH at the weekend if you want me to have a look???

Guy
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top