Rods 'n' Sods - UK Hot Rod & Street Rod Forums banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,142 Posts
Discussion Starter · #1 ·
hi
i have fitted disc brakes to my f100 56
and a remote servo and residue valves

now as i drive ,the brakes over time slowly start binding
so i have taken off the rear residue valve still the same

some one has said it may be the hose from the manifold to the remote servo may be collapsing

any help would be great

thanks richard
 

·
Registered
Joined
·
639 Posts
hi richard,
first thing i can think of which is the most common i've come across for this same issue was the master cylinder hadn't released fully,
in not coming back off it means you've got a hydraulic lock essentially which is ok till things warm up and expand then the caliper grabs the disc, more and more till it can lock on....
so in essence make sure the pedal is actually releasing FULLY.has it got a nice strong spring on the pedal?
obviously when it is the fluid is able to flow back to the master cylinder so no problem.....
neil
 

·
Premium Member
Joined
·
1,798 Posts
:yeahthat: the first thing I thought too. I replaces a m/c and the pedal wasn't completely releasing. It wasn't really noticeable until the brakes were used and they gradually locked on.

The servo just helps alter the mechanical effort required to apply the brakes. Even with a failed servo the brakes will still work without issue the pedal will just feel heavy.

Another option is check all the flexi-hoses. Old ones can internally collapse.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top