Rods 'n' Sods - UK Hot Rod & Street Rod Forums banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,797 Posts
Discussion Starter · #1 ·
I'm now getting close to getting the firebird MOT'd again but the indicators flash really fast. All 4 are working and they flash at the correct speed on hazzards but really quickly on indication.
 

·
Registered
Joined
·
28 Posts
Check the wattage of the indicator bulb they should each be 21w this will make the flasher unit flash at the 'correct' rate, because it works at the correct rate with the hazzards on it says to me the bulbs are too small a wattage.
 

·
Supercharged 461 cu in
Joined
·
1,407 Posts
Unless you have a bulb blown (one on each side) it is likely to be the flasher unit. Usually they are the same type for both the hazzards and the indicators (2 in total) try swapping them over if this is the case, because it is a loading issue. the "heavy" load relay is designed for all four bulbs, whilst the "lighter" one is for just two....one side or the other. Or if you go to Auto Electrical Components, Parts and Accessories for Trade and DIY: Polevolt Ltd they sell a flasher relay that is not load dependant. it works on a pulse timer so it just gives an equally spaced flash regardless of how many bulbs you have on the wire......great for towing too.

simon
 

·
Premium Member
Joined
·
1,797 Posts
Discussion Starter · #5 ·
Thanks for the replies. These all worked fine before the recent lay up and nothing has been altered. Nothing has been replaced. really doesn't make any sense.
 

·
Semi Proffessional Prat
Joined
·
3,489 Posts
Are they LEDs by any chance?
 

·
Semi Proffessional Prat
Joined
·
3,489 Posts
Check earths at rear. Alternatively put side lights and brake ligha and indicators on, and see if you have disco lights going on at back.
 

·
Premium Member
Joined
·
1,797 Posts
Discussion Starter · #10 ·
I've found there's seperate flasher units for the hazzards and indicators. I've swapped them round and the indicators now flash correctly but the hazzards are too fast. Thats not a major problem. Both units are 2 pins at 90deg to each other, is there an electronic version of this set up available?
 

·
Supercharged 461 cu in
Joined
·
1,407 Posts
I've found there's seperate flasher units for the hazzards and indicators. I've swapped them round and the indicators now flash correctly but the hazzards are too fast. Thats not a major problem. Both units are 2 pins at 90deg to each other, is there an electronic version of this set up available?
I did say this in my post above. the problem is just an out of limits flasher unit, just go and get a mini one or something similar then you will have TWO good ones, at the mo you have one good and one bad.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top